Yubico Forum

...visit our web-store at store.yubico.com
It is currently Tue Jan 30, 2018 12:35 pm

All times are UTC + 1 hour

Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Feb 19, 2017 2:23 pm 

Joined: Sun Feb 19, 2017 1:54 pm
Posts: 1

I have a new Yubikey 4 and I want to discovered it but I can't detect the key :/

I first tried with the personalization tool on a Ubuntu but it didn't recognize my key. I saw on the forum that I have to enable OTP first with neo-manager.
After installing neoman, I started it with sudo and my key was recognized ! :)
I clicked on the only button available ( It was something like "active OTP / CCID / U2F" ) and there were 3 checkboxes (OTP, CCID, U2F).
In my first try, I checked all three and validate, unplug / plug my key, nothing happened.
In second try, I only checked OTP and validate, unplug / plug ... and my key started making a green light in the (y) :)

Now, I still have the green light, but neoman don't recognize my key. I tried the personalization tool, but it detect nothing :/

Have I failed something ?

Thanks to help a newbie X)

More infos :
Neoman version 1.4.0.
when i start neoman, there are two warnings :
$ sudo neoman
Undefined symbol: yk_get_key_vid_pid
Undefined symbol: yk_get_capabilities

Reply with quote  

Share On:

Share on Facebook FacebookShare on Twitter TwitterShare on Tumblr TumblrShare on Google+ Google+

PostPosted: Mon Feb 20, 2017 10:06 pm 
Yubico Team
Yubico Team

Joined: Thu Oct 16, 2014 3:44 pm
Posts: 349
If you haven't already, make sure to add the Yubico PPA:

sudo add-apt-repository ppa:yubico/stable

Then update with apt-get update. Launch the YubiKey Personalization Tool to make sure you have the newest version of the library. The newest YubiKey 4 requires at least 1.17.3, currently (https://developers.yubico.com/yubikey-p ... ility.html).

You'll also want to take care of the udev rules for U2F and patch the Info.plist file for smart card functionality. Run the following command and restart:

sudo sh -c 'wget -q -O - https://raw.githubusercontent.com/Yubico/yubikey-neo-manager/master/resources/linux-fix-ccid-udev | python'

Then try again.

Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 1 hour

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group