Yubico Forum

yubico-c segmentation fault
Page 1 of 1

Author:  jtoon86 [ Wed Jun 20, 2012 2:50 pm ]
Post subject:  yubico-c segmentation fault

My server has been working great and yesterday attempted a login (yubico pam) and the server kicked me out. It has a segmentation fault with the yubico-c client. I attempted to rebuild but continue to have issues with the self checks:

Test selftest.c:108 (main): null client_id, expect REPLAYED_OTP
Segmentation fault (core dumped)
FAIL: selftest

I tried downloading the latest version from GIT but having issues compiling it. I downloaded 2.7 and was able to compile but receive the same error as above.

System: FreeBSD 6.3-RELEASE

Any suggestions on what might be causing the segmentation fault would be appreciated!

Author:  Klas [ Thu Jun 21, 2012 6:12 am ]
Post subject:  Re: yubico-c segmentation fault


What version have you been using previously?

Do you get the test error with 2.7 as well? and what problems do you get when trying to build 2.8?


Author:  jtoon86 [ Thu Jun 21, 2012 10:45 pm ]
Post subject:  Re: yubico-c segmentation fault

Installed version 2.7. When compiling v2.8 (I downloaded it from code.google.com and was able to compile), I get the following when running the test:

v2.8 (make check):
Assertion failed: (ret == YKCLIENT_REPLAYED_OTP), function main, file selftest.c, line 117.
Abort trap (core dumped)
FAIL: selftest
1 of 1 test failed
Please report to yubico-devel@googlegroups.com

When running ykclient v2.8, I get the following (yubikey otp obfuscated):
  client id: 16
  token: vvvcccjckcftcgfblljtknnfrditefgeunvihbuelkgv
Verification output (101): Could not parse server response

I suspect there is something else that is causing the issues on the server, but not sure exactly what this code is utilizing that might be causing the errors -- My other services seem to be running ok without issues (no other seg faults noted)

Author:  Klas [ Mon Jun 25, 2012 7:55 am ]
Post subject:  Re: yubico-c segmentation fault


The 2.8 version is broken with older versions of curl (which is probably shipped with freebsd 6.3) there are two fixes on github (https://github.com/Yubico/yubico-c-clie ... fe8b9c2880) for that. With those fixes added I can run the selftests and use ykclient on freebsd 6.3 with curl 7.16.3.

Can you test with that? If you still have issues, can you mail full output to me at klas@yubico.com?


Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group