Yubico Forum

[SOLVED]Unknown firmware
Page 1 of 1

Author:  fme [ Tue Feb 21, 2017 3:31 pm ]
Post subject:  [SOLVED]Unknown firmware


I'm testing a new YubiKey 4.
the yubikey-personalization-gui for Linux v3.1.25 shows me at the upper right "Unknown firmware"

below the flasing images: Firmware Version 4.3.4.

What's going wrong?



Author:  ChrisHalos [ Tue Feb 21, 2017 5:23 pm ]
Post subject:  Re: Unknown firmware

Make sure your version of yubikey-personalization is up to date (https://developers.yubico.com/yubikey-p ... ility.html).

Depending on the Linux build you will likely also need to update pcsc and add the udev rule for U2F devices (https://www.yubico.com/support/knowledg ... m-use-u2f/).

Author:  fme [ Thu Feb 23, 2017 12:13 pm ]
Post subject:  Re: [SOLVED]Unknown firmware

Thanks, after some crossreading your sites, I found the right tool and libs

Author:  kus [ Mon Jan 15, 2018 10:49 pm ]
Post subject:  Re: [SOLVED]Unknown firmware


I have the same question, therefore I don't want to start a new thread.

Bought a Yubikey Neo. Got "unknown firmware" warning, too.

Tested with recent windows binaries (App Version 3.1.24, Lib Version 1.17.3) and with the latest version from github with Linux (App Version 3.1.25, Lib 1.18.0) - both showed "unknown firmware".

My key a yubikey neo with firmware version 3.5.

Any advices?

Author:  ChrisHalos [ Tue Jan 16, 2018 10:35 pm ]
Post subject:  Re: [SOLVED]Unknown firmware

Install 3.1.25, it'll fix the issue - https://developers.yubico.com/yubikey-p ... /Releases/

This page will be updated soon as well - https://www.yubico.com/support/knowledg ... ion-tools/

Author:  kus [ Wed Jan 17, 2018 9:43 pm ]
Post subject:  Re: [SOLVED]Unknown firmware

If you read my post, I already installed and tested it with app version 3.1.25.

I just tried with version 3.1.26 from the master branch and the issue still exists.

Screenshot_20180117_214216.png [ 99.02 KiB | Viewed 403 times ]

Author:  ChrisHalos [ Thu Jan 18, 2018 5:45 pm ]
Post subject:  Re: [SOLVED]Unknown firmware

Linux - the library needs to be updated (yubikey-personalization)

https://developers.yubico.com/yubikey-p ... ility.html

1.18.1 is required for 3.5.X NEOs and 4.4.X YubiKey 4s.

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group