Yubico Forum

[QUESTION] Nano static password outputs wrong characters
Page 1 of 1

Author:  b0o [ Thu Dec 21, 2017 8:11 am ]
Post subject:  [QUESTION] Nano static password outputs wrong characters

I've had both a Yubikey Standard and a Yubikey Nano for quite a long time now, and my main use case involves static passwords.

Both my Standard and Nano are set up with the same static password in slot 1. All of my machines and Yubikeys are configured to use the en-US keyboard layout.

Everything has always worked great on all systems I've tried (Linux, OSX, Windows) for both Yubikeys until recently.

My problem started unexpectedly about a week ago:

When I trigger slot 1 of the Nano on my primary Linux machine, many of the characters are incorrect. Oddly, though, triggering slot 1 of the Standard outputs the correct characters. When I trigger the same Nano on another machine running macOS, the static password is output correctly.

Prior to this, both Yubikeys had been working as expected on this machine/OS for 6+ months. Around the time things stopped working, I didn't change any configuration settings on either Yubikey (I didn't even have the tools installed), and I didn't change any settings on my system which should have any affect on this. The only thing I can think of that may have caused this would be updating some program via my package manager, but I can't pinpoint what that may have been.

For reference, my machine is a Mid-2014 Macbook Pro (MacBookPro11,3) running Arch Linux (Linux 4.14.5-1-ARCH x86_64 GNU/Linux).

My Standard is Firmware Version 2.3.3, and my Nano is Firmware Version 4.3.3.

Here are some sample outputs from both Yubikeys with the specified static password programmed:

Static password:   abcABC123!@#
Yubikey Standard:  abcABC123!@#
Yubikey Nano:      abcaBC123123
Static password:   qwertyuiopasdfghjklzxcvbnm
Yubikey Standard:  qwertyuiopasdfghjklzxcvbnm
Yubikey Nano:      qwertyuiopasdfghjklzxcvbnm
Yubikey Nano:      qwertyuiopasdfghjklZXCVBNM
Static password:   `1234567890-=~!@#$%^&*()_+
Yubikey Standard:  `1234567890-=~!@#$%^&*()_+
Yubikey Nano:      `1234567890-=`1234567890-=

The only clue I may have found as to why this may be happening is the XKB keymaps for each Yubikey:

/bin/bash $ # find each Yubikey's device number
/bin/bash $ lsusb | grep Yubi
Bus 001 Device 025: ID 1050:0010 Yubico.com Yubikey (v1 or v2)
Bus 001 Device 022: ID 1050:0407 Yubico.com Yubikey 4 OTP+U2F+CCID
/bin/bash $ # output the loaded XKB keymap of each Yubikey
/bin/bash $ xkbcomp -i 025 $DISPLAY /tmp/yubikey-std.xkb
/bin/bash $ xkbcomp -i 022 $DISPLAY /tmp/yubikey-nano.xkb

I've uploaded both of the XKB files as well as a diff on GitHub Gist:
yubikey-std.xkb: https://gist.github.com/b0o/b681522b069 ... ey-std-xkb
yubikey-nano.xkb: https://gist.github.com/b0o/b681522b069 ... y-nano-xkb
diff yubikey-std.xkb yubikey-nano.xkb: https://gist.github.com/b0o/b681522b069 ... ikeys-diff

I'm not exactly sure how or why Linux decided to assign each Yubikey a different XKB keymap by default, because I have done nothing to change this myself.

Any help would be appreciated, I can provide more information upon request.

Thank you!

Author:  b0o [ Fri Dec 29, 2017 7:52 am ]
Post subject:  Re: [QUESTION] Nano static password outputs wrong character

Okay, oddly this issue seems to have resolved itself.

I messed around with some commands, including `xkbcomp`, `xmodmap`, and `setxkbmap`. I also performed a system update with `pacman`.

I'm not sure what specifically fixed it, but it works as expected now.

I'm not sure if I should mark this thread as [SOLVED] because I don't know what the solution was.

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group