Yubico Forum

USB port is loose, when pressed, no OTP generates
Page 1 of 1

Author:  paul [ Thu May 22, 2008 7:20 pm ]
Post subject:  USB port is loose, when pressed, no OTP generates

Do you feel Yubikey very loose in that USB port? In situations like
that, when pressing it the Yubikey loses the USB contact thus no
OTP shows up on the screen.

If that's the case, there are 2 solutions:

* Hold Yubikey's tight, when pressing the button, do not let it wiggle to lose
its USB contact with the USB port.

* Get an extension cable. They are tighter then the USB port on your PC thus
will hold Yubikey well and no room is left for wiggling.

Author:  Jakob [ Wed May 28, 2008 7:33 pm ]
Post subject:  Re: USB port is loose, when pressed, no OTP generates

Since about two weeks ago, for all units shipped the thickness have been slightly adjusted and we've put a tighter tolerance on our manufacturer.

If there is anyone experiencing problems with their key, please e-mail our support and we'll send you a replacement right away.


Jakob E
Hardware guy @ Yubico

Author:  Greg Woods [ Fri Jan 09, 2009 8:30 pm ]
Post subject:  Re: USB port is loose, when pressed, no OTP generates

The Yubikey I just ordered does not work in the USB ports on the side of our Dell monitors. It works fine in ports directly on the box, and it works in the monitor ports with an extension cable. My USB flash drive works fine directly in the monitor ports. I expect the monitor ports are "looser" than the ports on the box.

Author:  Jakob [ Sat Jan 10, 2009 6:07 pm ]
Post subject:  Re: USB port is loose, when pressed, no OTP generates

We've added a much more stringent thickness requirement at production nowadays. A few hundred keys of the very early batches (about 10-12 months ago) were a bit too thin. If you have such a key, please let us know and we'll provide a replacement.

The current production specification states a 2.35 mm thickness +/- 0.05

It is however important to understand that although the flat design we have provides significant benefits, it does not prevent the key from being inserted upside down and it does not have the same precise alignment as a "real" USB contact. We have had very few complaints and beleive it works really well.

With the best regards,

Hardware- and firmware guy @ Yubico.

Author:  Greg Woods [ Sun Jan 11, 2009 4:23 pm ]
Post subject:  Re: USB port is loose, when pressed, no OTP generates

I understand that a correction has been made to correct what used to be a more serious problem, but I am talking about Yubikeys that were ordered within the last month.

That said, my comment was not intended as a complaint. I believe that the "out of spec" problem in this case rests with the Dell monitor ports and not with the Yubikeys. There are certain flash drives that do not work in these ports either. Those are also very thin, do not have the full metal shield around the connector, and have a form factor very similar to the Yubikeys. The Yubikeys do work in every other port I have tried.

It is just unfortunate for us that many of our desktop users have those Dell monitors and of course those side ports will be the ones they would want to use for the Yubikey. We would have to get extension cables for them, which is an additional cost.

I really posted this just so that people would know that there exist some badly-designed USB ports in which the Yubikeys will not work.

Author:  Jakob [ Tue Jan 13, 2009 12:48 pm ]
Post subject:  Re: USB port is loose, when pressed, no OTP generates

Thanks for bringing this issue up. We are interested in hearing from people who have experienced problems.

Although the USB-A receptable specification is very consise, I've also seen contacts that are very loose and apparently out of spec. I have an noname USB hub here which is so loose that even ordinary USB-A plugs don't seat properly.


Hardware- and firmware guy @ Yubico

Author:  dlancelot [ Thu Apr 30, 2009 5:49 am ]
Post subject:  Re: USB port is loose, when pressed, no OTP generates

my yubikey feels loose in both my desktop and new acer aspire one laptop, but it always works in my desktop usb ports, but in my laptop the yubikey now works maybe 1 out of 100 tries...what could be wrong? windows xp pro recognizes it, it lights up solid green as if it's ready for use, but when I touch it, no OTP generates...I have tried it in many positions on all ports and nothing...could my usb drivers need reinstalling? what about the yubikey drivers? is there a way to reinstall those? or is it something else?

our organization has a few hundred of these things and a few others have had the same issues...I would like to relay any troubleshooting steps to them that we find out here.

I've cleaned the contacts with a super fine grit sandpaper as they looked tarnished...this hasn't seemed to help or hinder it's usage. it's still 100% in the desktop, and batting about 0.1% in the laptop. I also cleaned the oils from my fingers from it with a lysol brand wipes cloth (looks brand new now!), and still hasn't changed it's functionality.

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group