Yubico Forum

Yubikey & Password Save - General Issue or Config Problem?
Page 1 of 1

Author:  JRombach [ Thu Oct 24, 2013 6:24 pm ]
Post subject:  Yubikey & Password Save - General Issue or Config Problem?

I´m currently using Password Safe version V3.32.
In order to improve security I decided to use Password Safe with Yubikeys Challenge-Response based on HMAC-SHA1.
So I purchased Yubikey Firmware Version 2.4.1 preconfigured for Password Safe.
I followed the installation described by yubico: http://www.yubico.com/applications/password-management/consumer/password-safe/
Configuring an existing database for use with Yubikey was easy and works fine - every time I open the database I´m asked to press the Yubikey.

But: Without plugged in Yubikey no addl. auth-factor is required to open the database!
If no Yubikey is plugged, no Yubikey input field is displayed in the logon menue.
Everybody who knowns my master password has access to my secrets.
This renders the use of a Yubikey useless in my opinion.

Can someone confirm this behavior or give me hint, if I might have a mistake in the configuration?
Thanks a lot.

Author:  pepe [ Fri Oct 25, 2013 9:56 am ]
Post subject:  Re: Yubikey & Password Save - General Issue or Config Proble


My config is quite similar to yours. I run passwordsafe V 3.32 (German) on an Acer 5670. OS is Win XP full up-to-date. My yubikey - preconf. as "Yubikey for passwordsafe" - is FWV 2.4.2 I had a working passwordsafe before I got Yubikey. Now, what did I do when I received my Yubikey:

Following the instruction on the webpage you cited I jumped directly to "Installing & Configuring Password Safe for YubiKey" / ref 4. "If you already have an existing database....." I followed the instrucions and the Yubikey worked fine.

Now - after reading your post - I tried to open my passwordsafe in the manner you described. I can not confirm your finding My safe keeps shut with PW only and unplugged Yubikey.

BTW Did you configure Passwordsafe/Yubikey? --> menue "Verwalten" --> Yubikey?


Author:  JRombach [ Fri Oct 25, 2013 11:32 am ]
Post subject:  Re: Yubikey & Password Save - General Issue or Config Proble

Thanks for your reply. I found what was wrong.
I made the same mistake as described in this link http://sourceforge.net/p/passwordsafe/support-requests/372/.

I assume many users will make this mistake, its easy if you know:
You need to click on the YubiKey button on the screen <<< NOT on the Input-field >>> and then touch your YubiKey to access the database.

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group