Yubico Forum

Serial number: 0, yubikey broken?
Page 1 of 1

Author:  maggis [ Tue Sep 27, 2016 9:18 am ]
Post subject:  Serial number: 0, yubikey broken?

Why would a Yubikey NEO show with serial number 0 (zero) on EnrollmentStation? Is it broken?

Long story short, a user returned Yubikey NEO with comment that the PIN was blocked (who knows what really happened...honesty is in very short supply here). The usual reset PIN with EnrollmentStation did not work, and the whole YK worked very randomly:
- Most of the times, when plugged in Windows complained that the device had malfunctioned.
- yubico-piv-tool fails with "Failed to connect to reader." often.
- PIV Manager completely fails to find the device most of the time, but then sometimes after several minutes "Device Initialization" dialog pops up.

With several hours wasted inserting and removing the YK, finally yubico-piv-tool -a reset worked. But EnrollmentStation still shows serial number as zero and trying to enroll it ends with error dialog "Unable to reset the YubiKey", on top of that EnrollmentStation usually crashes after this error. Any ideas what to do?

Author:  ChrisHalos [ Tue Sep 27, 2016 5:14 pm ]
Post subject:  Re: Serial number: 0, yubikey broken?

Regarding the crash, you'd need to contact CSIS via GitHub. Serial number displayed as 0 is certainly possible on NEOs that are quite old (~ 3 years). If it's newer, the only possibility I can thing of is that API call has been turned off in the Personalization Tool (Settings > make sure API Call is checked > Update Settings > select a configuration slot that contains a credential > Update).

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group