Yubico Forum

...visit our web-store at store.yubico.com
It is currently Tue Jan 30, 2018 11:28 am

All times are UTC + 1 hour

Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Jan 25, 2015 9:42 pm 

Joined: Sun Jan 25, 2015 9:29 pm
Posts: 1
Hello everyone,

I am trying to use the CCID mode of my yubikey NEO to work correctly with my Mac OS X 10.9.5 Mavericks.

I have tried the following steps:

  1. Downloaded YubiKey NEO Manager 1.0.0
  2. Inserted YubiKey NEO and activated the CCID connection mode and replugged it.
  3. Downloaded the Apple SmartCard Services from https://smartcardservices.macosforge.org
  4. Installed the Apple SmartCard services v2.0.1 with the PIV tokend [50000]
  5. Rebooted the mac

When I now insert my yubikey NEO I see the following on my console

25.01.15 21:40:48,251 UserEventAgent[11]: assertion failed: 13F34: com.apple.telemetry + 16493 [AE0C3032-1747-317E-9871-E26B5B6B0120]: 0xffffffffe00002ed
25.01.15 21:40:48,907 com.apple.SecurityServer[15]: Token reader Yubico Yubikey NEO OTP+CCID 00 00 inserted into system
25.01.15 21:40:49,740 com.apple.SecurityServer[15]: token in reader Yubico Yubikey NEO OTP+CCID 00 00 cannot be used (error 229)

The compiled yubikey-piv-tool works with the yubikey: I can import certificates into the yubikey, check the PIN, etc. However in the Keychain Application there is no new keychain representing the YubiKey NEO.

I already tried reinstalling SmartCard services but without luck.

How can I make it work on my mac?

Reply with quote  

Share On:

Share on Facebook FacebookShare on Twitter TwitterShare on Tumblr TumblrShare on Google+ Google+

PostPosted: Fri Mar 13, 2015 3:03 pm 

Joined: Wed Jan 14, 2015 11:34 am
Posts: 24
I know this is a kind-of-late reply, but it could help others
I haven't tried on 10.9.x, only on 10.10 - Yosemite

1) in my case, the tokend from smartcardservices wasn't working too well - had to use the CACkey tokend, but YMMV - you should try what works best for you.
^ This could be only the case with Yosemite as things are in flux here and some bugs apply to all smartcards, not just Yubikey - so disregard if tokend is working for you
2) You need to have the Yubikey PIV applet personalized before trying to use it - that's why you get that error message. Import your cert+key into the appropriate slot and reinsert - it will show up in keychain after that

Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 1 hour

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group