Yubico Forum

...visit our web-store at store.yubico.com
It is currently Thu Feb 22, 2018 12:05 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: [SOLVED]Unknown firmware
PostPosted: Tue Feb 21, 2017 3:31 pm 
Offline

Joined: Tue Feb 21, 2017 3:09 pm
Posts: 5
Hi,

I'm testing a new YubiKey 4.
the yubikey-personalization-gui for Linux v3.1.25 shows me at the upper right "Unknown firmware"

below the flasing images: Firmware Version 4.3.4.


What's going wrong?


Thanks

Frank


Last edited by fme on Thu Feb 23, 2017 12:12 pm, edited 1 time in total.

Top
 Profile  
Reply with quote  

Share On:

Share on Facebook FacebookShare on Twitter TwitterShare on Tumblr TumblrShare on Google+ Google+

 Post subject: Re: Unknown firmware
PostPosted: Tue Feb 21, 2017 5:23 pm 
Offline
Yubico Team
Yubico Team

Joined: Thu Oct 16, 2014 3:44 pm
Posts: 349
Make sure your version of yubikey-personalization is up to date (https://developers.yubico.com/yubikey-p ... ility.html).

Depending on the Linux build you will likely also need to update pcsc and add the udev rule for U2F devices (https://www.yubico.com/support/knowledg ... m-use-u2f/).


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 23, 2017 12:13 pm 
Offline

Joined: Tue Feb 21, 2017 3:09 pm
Posts: 5
Thanks, after some crossreading your sites, I found the right tool and libs


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 15, 2018 10:49 pm 
Offline

Joined: Mon Jan 15, 2018 10:30 pm
Posts: 2
Hey,

I have the same question, therefore I don't want to start a new thread.

Bought a Yubikey Neo. Got "unknown firmware" warning, too.

Tested with recent windows binaries (App Version 3.1.24, Lib Version 1.17.3) and with the latest version from github with Linux (App Version 3.1.25, Lib 1.18.0) - both showed "unknown firmware".

My key a yubikey neo with firmware version 3.5.

Any advices?
Thanks!


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 16, 2018 10:35 pm 
Offline
Yubico Team
Yubico Team

Joined: Thu Oct 16, 2014 3:44 pm
Posts: 349
Install 3.1.25, it'll fix the issue - https://developers.yubico.com/yubikey-p ... /Releases/

This page will be updated soon as well - https://www.yubico.com/support/knowledg ... ion-tools/


Top
 Profile  
Reply with quote  
PostPosted: Wed Jan 17, 2018 9:43 pm 
Offline

Joined: Mon Jan 15, 2018 10:30 pm
Posts: 2
If you read my post, I already installed and tested it with app version 3.1.25.

I just tried with version 3.1.26 from the master branch and the issue still exists.


Attachments:
Screenshot_20180117_214216.png
Screenshot_20180117_214216.png [ 99.02 KiB | Viewed 787 times ]
Top
 Profile  
Reply with quote  
PostPosted: Thu Jan 18, 2018 5:45 pm 
Offline
Yubico Team
Yubico Team

Joined: Thu Oct 16, 2014 3:44 pm
Posts: 349
Linux - the library needs to be updated (yubikey-personalization)

https://developers.yubico.com/yubikey-p ... ility.html

1.18.1 is required for 3.5.X NEOs and 4.4.X YubiKey 4s.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group